Skip to content


[java.lang.UnsupportedClassVersionError: … (Unsupported major.minor version 49.0)]

[java.lang.UnsupportedClassVersionError: … (Unsupported major.minor version 49.0)]

Why can I not remember that an ‘Unsupported major.minor version 49.0’ means ‘you can’t run a class compiled with JDK 1.5 in JRE 1.4?’ Yesterday, jad was complaining about it, but it still didn’t occur to me until put the class files in a jar file.

Posted in Java.


0 Responses

Stay in touch with the conversation, subscribe to the RSS feed for comments on this post.



Some HTML is OK

or, reply to this post via trackback.